cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Showing results for 
Search instead for 
Did you mean: 
Adweta
Participant
  • 0
  • 1
  • 0
Registered since

Aug 12, 2020

Soundlink revolve red blinking power indicator

Hi, My sound link revolve power indicator is blinking red when put on charge . Tried resetting by pressing the power button for 10 secs .... but of no avail . What needs to be done . Please suggest.

Thank you .

2 REPLIES 2
Sam_F
Moderator

Re: Soundlink revolve red blinking power indicator

Hey @Adweta,

 

I'm sorry to hear you're having some trouble using and charging your SoundLink Revolve speaker. A reset would have been recommended, so it's good to know you've tried that already. Have you tried updating the firmware of the speaker HERE, to see if you get any different response from the speaker? Also, try using a different charging cable and power socket/outlet, just to ensure we've tried all possible troubleshooting.

 

If you notice things still do not improve after trying all of this, then it's best if we look towards servicing your speaker. The best route will be to reach out to your local support team who'll be more than happy to guide you on how to fix your speaker. To do this, go to Global Contact Page > Select your country > Scroll to the bottom of the page > Click 'Contact Us'. Let me know how you get on!

joelirwin
Expert
  • 393
  • 1910
  • 73
Registered since

Jun 15, 2018

Re: Soundlink revolve red blinking power indicator

@Sam_F @Adweta With all due respect for Bose, there is likely nothing wrong with the batteries.  I had two Revolves go back earlier this year and the 'fixed' units continued to have the problem.  So they were both exchanged for two brand new units and one of the new units had the problem.  So it actually happened to me 6 times.

I have reason to believe that the problem is firmware related and have asked for Bose moderator comment on this many times here since January but have yet to get a response and my separate posts are deemed 'similar' to other posts and my requests for comment go unnoticed when they are buried in a 'similar' post.

Unless otherwise suggested by Bose, I believe the problem is that users are either unaware or tend to disregard the fact that the Revolve requires around 1.55 amps to correct charge and by charging it in a 1 amp USB port (such as the ones on most computers and monitors and one lightning bolt USBs on battery chargers), something gets messed up internally in the Revolve which prevents it from properly charging no matter what the Revolve is plugged into - even a 2 amp port.  A Revolve can only be charged through a wall socket with a brick charger or a 2 amp (two lightning bolt) battery charger.  I wish the Revolve will stop itself from being undercharged but it doesn't currently.

From what I can tell, the 'standard' Bose resetting approach will not fix or clear out the problem.  There is a modified approach/procedure which seems to work though sometimes it has to be done multiple times.  I can say it fixed my Revolves all 6 times and couple here have had success but there are no guarantees.

 

It has been shared in many of the posts on this battery topic.  I'll go look for a copy and provide a link here.

Good luck and remember to ALWAYS charge your speakers like the Revolve in ONLY a 2 amp USB port.

 

https://community.bose.com/t5/Portable/Soundlink-Revolve-won-t-charge/td-p/186627/page/6